私はPaul HegartyのスタンフォードCS193Pから勉強しています。それで、私はこのようなものを見て、他の人が使っているのを見ます:はif(self){[self initFOO]} redundant?
- (id)init
{
self = [super init];
if (self) {
[self someSetupFunctions];
}
return self;
}
冗長ではありませんか?なぜ使用しないだけでいいですか:
- (id)init
{
self = [super init];
[self someSetupFunctions];
return self;
}
私はメッセージがなくなるのを防ぐため、この2番目のフォーマットは使用しないでください。