2016-12-10 1 views
0

Ellipse2D.doubleクラスが見つかりました。 円が四角形(class.rect)と衝突するかどうかをチェックするのに最適なクラスです。 私の問題は、Java/Android Projectに統合できないということです。 Ellipse2D.doubleを拡張する必要があるオブジェクトを宣言したい場合は、「シンボル 'Ellipse2D'を解決できません」と表示されます。 Ellipse2D SDKなど何も見つかりませんでしたので、問題の原因がわかりません。"シンボル 'Ellipse2D'を解決できません"

答えて

2

Ellipse2Dクラスは、JavaベースのGUIアプリケーションを開発するためのAPIであるjava.awt.geomパッケージに含まれています。このパッケージは、Android SDKではGUIを構築するための他のクラスを提供するため、Android APIでは利用できません。 OvalShapeまたはRectFここで説明するクラス:Differences between drawing an Ellipse in Android and Java

+1

クイック応答ありがとう。私はRectFクラスをチェックアウトします:) –

関連する問題