2017-12-31 93 views
2

私がインストールしよう:私は、私が代わりに3.6のpythonの3.5を実行しているためであると思われる"h2o4gpu-0.1.0-py36-none-any.whlはこのプラットフォームではサポートされていません。"

h2o4gpu-0.1.0-py36-none-any.whl is not a supported wheel on this platform. 

sudo pip3 install h2o4gpu-0.1.0-py36-none-any.whl 

私は(そう有用ではない)エラーMSGを取得します。私のpython 3.6にアップグレードしようとすると、しかし、私は私が何をするか分からない船尾/怖い警告、...

答えを周りグーグル
sudo add-apt-repository ppa:jonathonf/python-3.6 
A plain backport of *just* Python 3.6. System extensions/Python libraries may or may not work. 

Don't remove Python 3.5 from your system - it will break. 
More info: https://launchpad.net/~jonathonf/+archive/ubuntu/python-3.6 
Press [ENTER] to continue or ctrl-c to cancel adding it 

を取得し、私は、これに遭遇しませんでしたこれはPython 3.5は3.6のパッケージをサポートするつもりはないことを示している可能性があります:

python3 
Python 3.5.2 (default, Nov 23 2017, 16:37:01) 
[GCC 5.4.0 20160609] on linux 
Type "help", "copyright", "credits" or "license" for more information. 
>>> import pip 
>>> print(pip.pep425tags.get_supported()) 
[('cp35', 'cp35m', 'manylinux1_x86_64'), ('cp35', 'cp35m', 'linux_x86_64'), ('cp35', 'abi3', 'manylinux1_x86_64'), ('cp35', 'abi3', 'linux_x86_64'), ('cp35', 'none', 'manylinux1_x86_64'), ('cp35', 'none', 'linux_x86_64'), ('cp34', 'abi3', 'manylinux1_x86_64'), ('cp34', 'abi3', 'linux_x86_64'), ('cp33', 'abi3', 'manylinux1_x86_64'), ('cp33', 'abi3', 'linux_x86_64'), ('cp32', 'abi3', 'manylinux1_x86_64'), ('cp32', 'abi3', 'linux_x86_64'), ('py3', 'none', 'manylinux1_x86_64'), ('py3', 'none', 'linux_x86_64'), ('cp35', 'none', 'any'), ('cp3', 'none', 'any'), ('py35', 'none', 'any'), ('py3', 'none', 'any'), ('py34', 'none', 'any'), ('py33', 'none', 'any'), ('py32', 'none', 'any'), ('py31', 'none', 'any'), ('py30', 'none', 'any')] 

その他のシステム情報:

  • のUbuntu 16.04
  • クーダ8
  • cudnn 6
  • PIP 9.0.1
  • パイソン3.5
  • x86_64の
  • NVidiaの1080

他のノート。 https://github.com/h2oai/h2o4gpuは、どのPythonが必要かについてはっきりしていませんが、ファイル名がこのことを明確にしていると思われます。 (これは、h2o4gpuがPython 2.7では動作しないことを意味すると私は推測する)。

READMEファイルは、ncclの内容を明示していません。 Googleからは、ncclが複数のGPUを持っていることを意味していると推測しています(私には1つしかありません)。

ご協力いただけると助かります。

+0

Readmeは、downloadaが「Python 3.6」であると言っています。あなたは2.7/3.5でそれを使用することはできません。 python 3.6をインストールし、h2o4gpu用にpyenvまたはvirtualenvを作成することをお勧めします。 NCCLについては、リンクを追加することをお勧めします。マルチGPUシステムには本当に必要です。 –

答えて

0

(私は十分評判ポイントを持っていないので、私はh2o4gpuタグを追加することができます。申し訳ありませんが)のUbuntu 16.04上のpython 3.6を実行するためのrecommended wayhttps://launchpad.net/~jonathonf/+archive/ubuntu/python-3.6でPPAを使用することです(とあなたがしてpython3.6でそれを実行する必要が覚えています) 。

は16.10と17.04のためには、PPAを必要としないし、ちょうど、代わりsudo apt-get install python3.6

を行うのUbuntu 17.10にシステムをアップグレードすることができますし、システムのpythonになります3.6をPYTHON。 (17.10は長期サポートリリースではないので、4月にリリースされたときに18.04 LTSにアップグレードする予定です)

関連する問題