2016-04-14 13 views
3

私は次のエラーのためCoreOS 991.1.0/GCEにKubernetes 1.2.0とcluster/addons/cluster-monitoring/google/heapster-controller.yamlをインストールすることができません:なぜGoogle Heapster Kubernetesアドオンをインストールできないのですか?

Error from server: error when creating "/tmp/heapster-controller.yaml": Deployment in version extensions/v1beta1 cannot be handled as a Deployment: json: cannot unmarshal object into Go value of type string What is going wrong here?

マイheapster-controller.yamlは、この(テンプレートから展開)のようになります。

apiVersion: extensions/v1beta1 
kind: Deployment 
metadata: 
    name: heapster-v1.0.2 
    namespace: kube-system 
    labels: 
    k8s-app: heapster 
    kubernetes.io/cluster-service: "true" 
    version: v1.0.2 
spec: 
    replicas: 1 
    selector: 
    matchLabels: 
     k8s-app: heapster 
     version: v1.0.2 
    template: 
    metadata: 
     labels: 
     k8s-app: heapster 
     version: v1.0.2 
    spec: 
     containers: 
     - image: gcr.io/google_containers/heapster:v1.0.2 
      name: heapster 
      resources: 
      # keep request = limit to keep this container in guaranteed class 
      limits: 
       cpu: 100m 
       memory: 200Mi 
      requests: 
       cpu: 100m 
       memory: 200Mi 
      command: 
      - /heapster 
      - --source=kubernetes.summary_api:'' 
      - --sink=gcm 
      - --metric_resolution=60s 
      volumeMounts: 
      - name: ssl-certs 
       mountPath: /etc/ssl/certs 
       readOnly: true 
     - image: gcr.io/google_containers/heapster:v1.0.2 
      name: eventer 
      resources: 
      # keep request = limit to keep this container in guaranteed class 
      limits: 
       cpu: 100m 
       memory: 200Mi 
      requests: 
       cpu: 100m 
       memory: 200Mi 
      command: 
      - /eventer 
      - --source=kubernetes:'' 
      - --sink=gcl 
      volumeMounts: 
      - name: ssl-certs 
       mountPath: /etc/ssl/certs 
       readOnly: true 
     - image: gcr.io/google_containers/addon-resizer:1.0 
      name: heapster-nanny 
      resources: 
      limits: 
       cpu: 50m 
       memory: 100Mi 
      requests: 
       cpu: 50m 
       memory: 100Mi 
      env: 
      - name: MY_POD_NAME 
       valueFrom: 
       fieldRef: 
        fieldPath: metadata.name 
      - name: MY_POD_NAMESPACE 
       valueFrom: 
       fieldRef: 
        fieldPath: metadata.namespace 
      command: 
      - /pod_nanny 
      - --cpu=100m 
      - --extra-cpu=0m 
      - --memory=200Mi 
      - --extra-memory=4Mi 
      - --threshold=5 
      - --deployment=heapster-v1.0.2 
      - --container=heapster 
      - --poll-period=300000 
     - image: gcr.io/google_containers/addon-resizer:1.0 
      name: eventer-nanny 
      resources: 
      limits: 
       cpu: 50m 
       memory: 100Mi 
      requests: 
       cpu: 50m 
       memory: 100Mi 
      env: 
      - name: MY_POD_NAME 
       valueFrom: 
       fieldRef: 
        fieldPath: metadata.name 
      - name: MY_POD_NAMESPACE 
       valueFrom: 
       fieldRef: 
        fieldPath: metadata.namespace 
      command: 
      - /pod_nanny 
      - --cpu=100m 
      - --extra-cpu=0m 
      - --memory=200Mi 
      - --extra-memory=500Ki 
      - --threshold=5 
      - --deployment=heapster-v1.0.2 
      - --container=eventer 
      - --poll-period=300000 
     volumes: 
     - name: ssl-certs 
      hostPath: 
      path: "/etc/ssl/certs" 

答えて

1

クライアントとサーバーのバージョンが一致していないようです。 this GitHub issueで詳細を読む。

関連する問題